Our system can't connect to teamspeak

Incident Report for Ranch Roleplay Status

Resolved

This incident has been resolved.
Posted Mar 19, 2025 - 04:45 UTC

Investigating

Our automatic systems have reported that they cannot connect to our teamspeak server. We are now investigating and will give an update on Discord as soon as possible.
Posted Mar 19, 2025 - 04:43 UTC
This incident affected: Core Services (Teamspeak Server).